TriCore Upload executable file in UDEVisualPlatform

UDEVisualPlatform

  • File -> New Workspace

.wsx ํŒŒ์ผ์„ ์ €์žฅ ํ›„, New ๋ฒ„ํŠผ์„ ๋ˆ„๋ฅด๊ณ  ์‚ฌ์šฉ ์ค‘์ธ ๋ณด๋“œ๋ฅผ ์ฐพ์•„ ์„ ํƒํ•ฉ๋‹ˆ๋‹ค.

  • New
  • Use a default target configuration -> TriCore -> Hitex -> ShieldBuddy -> Hitex ShieldBuddy with TC275T D-Step (Multicore Configuration)
  • Finish

.cfg ํŒŒ์ผ์„ ์ €์žฅ ํ›„, OK ๋ฒ„ํŠผ์„ ๋ˆŒ๋Ÿฌ ์„ค์ •์„ ๋๋ƒ…๋‹ˆ๋‹ค.

์žฅ์น˜๊ฐ€ ์ปดํ“จํ„ฐ์— ์—ฐ๊ฒฐ๋˜์–ด ์žˆ์—ˆ๋‹ค๋ฉด ์ž๋™์œผ๋กœ ์—ฐ๊ฒฐ๋ฉ๋‹ˆ๋‹ค. ๊ทธ๋ ‡์ง€ ์•Š์€ ๊ฒฝ์šฐ File -> Connect Target System์„ ์„ ํƒํ•˜์—ฌ ์—ฐ๊ฒฐ์„ ์‹œ๋„ํ•ฉ๋‹ˆ๋‹ค.

Load

  • File -> Load Program
  • <workspace>\<project>\2_Out\Tricore_Gnuc\<project>.elf

์ด๋ฏธ ๋ถˆ๋Ÿฌ์˜จ ๊ฒฝ์šฐ ์•„๋ž˜์™€ ๊ฐ™์€ ์ฐฝ์ด ๋œน๋‹ˆ๋‹ค. ๋…ธ๋ž€์ค„ ์นœ ๋ถ€๋ถ„์˜ ์ฒซ๋ฒˆ์งธ ๋ฒ„ํŠผ์ด ์ƒˆ๋กœ์šด ํŒŒ์ผ์„ ๋ถˆ๋Ÿฌ์˜ค๋Š” ๋ฒ„ํŠผ์ด๊ณ , ๋‘๋ฒˆ์งธ ๋ฒ„ํŠผ์ด ์ฒดํฌ๋œ ํŒŒ์ผ์„ ๋“ฑ๋ก์—์„œ ์‚ญ์ œํ•˜๋Š” ๋ฒ„ํŠผ์ž…๋‹ˆ๋‹ค.

Upload

์ƒˆ๋กœ์šด ํŒŒ์ผ์„ ๋ถˆ๋Ÿฌ์˜ค๋ฉด ํ”„๋กœ๊ทธ๋žจ์„ ์—…๋กœ๋“œํ•  ์ˆ˜ ์žˆ๋Š” ์ฐฝ์ด ์ž๋™์œผ๋กœ ์—ด๋ฆฝ๋‹ˆ๋‹ค. Program All์„ ๋ˆŒ๋Ÿฌ ๋ณด๋“œ๋กœ ์—…๋กœ๋“œ ํ•˜๋ฉด ๋ฉ๋‹ˆ๋‹ค. ์—…๋กœ๋“œ ํ›„์— ์ฝ”๋“œ๋ฅผ ๋ณ€๊ฒฝํ•˜๊ณ  ๋‹ค์‹œ ๋นŒ๋“œํ•˜๋ฉด UDEVisualPlatform์ด ๋ฐ”์ด๋„ˆ๋ฆฌ์˜ ๋ณ€ํ™”๋ฅผ ๊ฐ์ง€ํ•˜๊ณ  ์—…๋กœ๋“œํ•  ๊ฒƒ์ธ์ง€ ๋ฌป๋Š” ์ฐฝ์„ ์ž๋™์œผ๋กœ ์—ด์–ด์ค๋‹ˆ๋‹ค.

์ž๋™์œผ๋กœ ์—ด๋ฆฌ์ง€ ์•Š์œผ๋ฉด Tools -> FLASH Programming์„ ๋ˆŒ๋Ÿฌ ์—…๋กœ๋“œ์ฐฝ์„ ์—ฐ ํ›„ Program All์„ ๋ˆŒ๋Ÿฌ ์—…๋กœ๋“œํ•˜์‹œ๋ฉด ๋ฉ๋‹ˆ๋‹ค.

Start

  • Debug -> Start Program Execution(F5)
  • Debug -> Reset target(Ctrl + F7)
Last updated on